Degraded experience adding and accessing media attachments

Incident Report for Atlas

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 09:38 UTC

Investigating

We are investigating an issue causing a degraded experience when adding attachments or accessing existing media content.
Posted Jul 30, 2025 - 07:10 UTC
This incident affected: API and Signup.